[arch-haskell] Questions related dependencies of packages in [extra] & [community]

Magnus Therning magnus at therning.org
Sat Oct 12 07:39:28 UTC 2013

I have 3 questions related to dependencies for haskell packages:

1. I noticed that the haskell packages in [extra] and [community] now
   depend on a specific revision (7.0.3-2) rather than just a specific
   version (e.g. 7.0.3) of ghc.  Is this to make sure that if there is
   an ABI change due to a bump in the revision then users don't end up
   with an unusable system?

2. There are some dependencies on other haskell packages that also
   require a specific revision (e.g. haskell-haskeline).  This does
   strike me as a good idea, again to prevent inconsistent user
   systems.  It isn't consistent though (again, e.g.
   haskell-haskeline, its dependency on haskell-terminfo).  Is it a
   bug that should be reported?

3. I also noticed the dependency on 'sh' for the first time.  This
   strikes me as something that ought to be superfluous, isn't it?


Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

Most software today is very much like an Egyptian pyramid with
millions of bricks piled on top of each other, with no structural
integrity, but just done by brute force and thousands of slaves.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20131012/be075039/attachment.sig>

More information about the arch-haskell mailing list