[arch-haskell] Upgrading to GHC 7

gdweber at iue.edu gdweber at iue.edu
Sat Oct 12 07:39:00 UTC 2013

This is a reminder to those who are flummoxed by all of those
messages when you do 'pacman -Syu':

error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-cairo: requires haskell-array=
:: haskell-cairo: requires haskell-bytestring=
:: haskell-cairo: requires haskell-haskell98=
:: haskell-citeproc-hs: requires haskell-http=4000.0.9
:: haskell-citeproc-hs: requires haskell-bytestring=
:: haskell-citeproc-hs: requires haskell-containers=

-- and many more of a similar nature.

Now that GHC 7 has moved from [staging] to [extra], we need to
remove and re-install everything haskellish, and this is the
procedure (taken from peti's comment on the AUR haskell-pong
package, posted to the arch-haskell list on 2011 Jan 16):

1.  Remove ghc and everything that depends on it:

        pacman -R --cascade ghc
        rm -rf /usr/lib/ghc-*

    (Wow, it's been a while since I've done that 'rm' bit --
    this time it's cleaning out directories from as far back
    as ghc 6.10.3!)

2.  Re-install ghc and everything else you need from scratch

    At the moment, re-installing _everything_ will _not_ work
    (more about that in another message), but installing Haskell
    Platform --

        pacman -S haskell-platform

    does work, with no problem at all.  And since I had never
    actually installed the Haskell Platform before, per se,
    it was a pleasure to see it working!

   ___   ___  __     _      
  / _ \ / _ \| |    | |     Gregory D. Weber, Associate Professor
 / /_\// / | | | /\ | |     Indiana University East
/ /_\\/ /__| | |/  \| |     http://mypage.iu.edu/~gdweber/
\____/\_____/\___/\__/      Tel. (765) 973-8420; FAX (765) 973-8550

More information about the arch-haskell mailing list