[arch-haskell] Adding another data file for dependency "hints"

Magnus Therning magnus at therning.org
Sat Oct 12 07:37:51 UTC 2013

On Sun, Jan 2, 2011 at 11:39, Peter Simons <simons at cryp.to> wrote:
> Rémy Oudompheng writes:
>  > https://github.com/archhaskell/cabal2arch/issues#issue/19.
> the gist of this issue is that "parsec >= 3.0 || == 2.1.*" is translated to
> "parsec>=3.0", which is just plain wrong. Now, wouldn't it be easiest to
> modify cabal2arch so that it translates that specification to "parsec>=2.1"?
> A straight-forward algorithm to accomplish that would be to use the *lowest*
> version bound in these kinds of alternatives. Right now, cabal2arch appears
> to be using the *first* version bound, which is not exactly optimal.
> Am I missing something?

Well, there's an obvious problem with what you suggest, since
"parsec>=2.1" is plain wrong too!

How common is this type of dependencies in practice?
Personally I wouldn't write a dependency like that, instead I'd use a
flag, but trying to enforcing that behaviour would be plain silly :)


Magnus Therning                      OpenPGP: 0xAB4DFBA4
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

More information about the arch-haskell mailing list