[arch-haskell] Re: [extra] haskell-parallel

Peter Simons simons at cryp.to
Sat Oct 12 07:37:36 UTC 2013

Hi Xyne,

 > Why does haskell-parallel in [extra] depends on a later version of
 > haskell-deepseq than what is availabe in [extra]? The package simply
 > cannot be installed because of this.

on top of this, [extra] ships parallel-, which is way ahead of
the version haskell-platform requires, namely parallel-

There are other problems in [extra] (such as FS#21615 and FS#21613), all
of which have been reported a while ago, but still there seems to be no
discernible progress towards remedying the situation. This is really
frustrating. I thought Remy volunteered to help maintaining [extra]
precisely to avoid these kind of problems. So what is going on? What is
the point of me bothering to maintain AUR, if our base packages in
[extra] are outright broken for extended periods of time?

Take care,

More information about the arch-haskell mailing list