[arch-haskell] Re: archlinux v0.3.5 and cabal2arch v0.7.6

Peter Simons simons at cryp.to
Sat Oct 12 07:37:31 UTC 2013

Hi Magnus,

 > This is a minor point, but is the new version of archlinux (0.3.5) really
 > API compatible with the previous version (0.3.4)?

yes, I believe it is. I certainly tried to make all changes in a backwards
compatible manner.

 > If the answer is 'no', then the newer version ought to be 0.4 (or 0.4.0).
 > [...] I would also argue that cabal2arch is bumped to 0.8 (or 0.8.0) to
 > clearly mark that the UI has changed and isn't compatible with the previous
 > version (0.7.5).

Yes, I think a major version bump is in order simply because there have been
plenty of changes to both archlinux and cabal2arch. How about bumping the
version number for both packages to 1.0? They appear to be well out of beta
state, so it feels like we should have an 1.x release.

Take care,

More information about the arch-haskell mailing list