[arch-haskell] Why is haskell-utf8-string installed?

Magnus Therning magnus at therning.org
Sat Oct 12 07:35:51 UTC 2013

On Tue, Jan 19, 2010 at 7:12 AM, Don Stewart <dons at galois.com> wrote:
> magnus:
>> I suspect this is a bug in pacman, but would really like someone else to
>> confirm that I'm not just confused ;-)
>> I just removed all my haskell-related packages and re-installed the bare
>> minimum I need:
>> % sudo pacman -Rncs ghc
>> % sudo pacman -S xmonad-contrib
>> After this I find that I have two versions on utf8-string:
>> % ghc-pkg list|grep utf8
>>     utf8-string-0.3.4
>>     utf8-string-0.3.6
> GHC 6.12 provides utf8-string, is that involved?

Well, that's really the whole point of my email.  Probably very
clumsily asked though.

Yes, GHC 6.12 provides utf8-string 0.3.4, neither xmonad-contrib nor
haskell-x11-xft rely on any particular version (anything >=0.3
satisfies both).  Yet pacman installed haskell-utf8-string (0.3.6).
It looks like pacman didn't take into consideration that ghc (the Arch
package) provides haskell-utf8-string[1].  In other words, it looks to
me like pacman's dependency resolution has a bug.  With my usual doubt
in my own abilities I was wondering if there isn't a fault in my logic


[1]: http://repos.archlinux.org/wsvn/packages/ghc/repos/extra-x86_64/PKGBUILD

Magnus Therning                        (OpenPGP: 0xAB4DFBA4)
magnus@therning.org          Jabber: magnus@therning.org
http://therning.org/magnus         identi.ca|twitter: magthe

More information about the arch-haskell mailing list