[arch-haskell] cabal2arch 0.6.1 now generates bad dependencies

Tasha Buckley etherealgoddess at gmail.com
Sat Oct 12 07:35:41 UTC 2013

On Sat, Jan 16, 2010 at 5:04 AM, Magnus Therning <magnus at therning.org> wrote:
> I thought 6.10 came with Cabal as well, and that it was dealt with by
> having 'ghc' provide 'haskell-cabal' in Arch.
These points are all true, but yaourt (the tool most people use and
what's recommended in the wiki) doesn't seem to respect this and it
seems kind of odd to me to have haskell-cabal an an explicit dep when
none of ghc's other known provided packages are made explicit. Finally
and most importantly, the main issue is that these are literally the
only dependencies being generated. For example, many new 6.12 packages
require mtl, but that's not being placed in the depends array.

More information about the arch-haskell mailing list