[arch-haskell] Leksah depends on haddock which isn't listed in ghc-pkg

Leif Warner abimelech at gmail.com
Sun May 8 23:14:21 CEST 2011

I was trying to add the IDE Leksah, and some of the parts have dependencies
on specific versions of haddock.  Haddock is provided by the ghc package,
but it's not listed in ghc-pkg list.  I can take the lines mentioning
haddock dependencies out of .cabal files (since that's provided anyways),
but some of the source files, e.g. line 150 of
src/IDE/Metainfo/SourceCollectorH.hs in the leksah-server package, have cpp
directives like:
 #if MIN_VERSION_haddock(2,8,0)

Is there some kind of workaround for this?  Let it know haddock is already
there?  Patch those files myself to the appropriate haddock version?

-Leif Warner
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20110508/ec3dbc26/attachment.htm>

More information about the arch-haskell mailing list