[arch-haskell] Latest yesod/mime-mail combination is broken?

Andrew Myers asm198 at gmail.com
Wed Dec 28 00:00:57 CET 2011

Hi all,
Is that latest Yesod + mime-mail broken or am I doing something stupid?  I
can install everything just fine but when I do

> yesod init
> Project Name: test
> Foundation: Test
> cd test
> cabal configure

I get
Resolving dependencies...
Configuring test-0.0.0...
cabal: At least the following dependencies are missing:
mime-mail >= && <0.4


> pacman -Ss haskell-mime-mail
haskell/haskell-mime-mail 0.3.0-3 [installed]
    Compose MIME email messages.

Note the '-' in the third place where there was a '.' in the third place on
the 'cabal configure' command.

If I 'cabal install' mime-mail this only results in more confusion and
breakage for cabal, as you might expect.

> cabal install 'mime-mail <0.4'
Resolving dependencies...
(... Snip ...)
Registering mime-mail-

> cabal configure
Resolving dependencies...
Configuring personal-website-0.0.0...
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
package mime-mail-0.3.0 requires dataenc-
package mime-mail- requires dataenc-
package yesod-auth-0.7.5 requires mime-mail-0.3.0
package personal-website-0.0.0 requires mime-mail-

It seems I can't use the current version of yesod that's in the Arch
Haskell repositories because of this.  Any suggestions?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20111227/f54dbbf7/attachment.htm>

More information about the arch-haskell mailing list