[arch-haskell] Heads up: QC1 dependencies break some distros

Don Stewart dons at galois.com
Sun Jan 31 14:14:59 EST 2010

Hey John,

Just a heads up. Some of your packages depend on QuickCheck 1. The
Haskell Platform upcoming release will use QuickCheck 2 by default, and
we expect most distros to move to QC2. This means for example, that
testpack won't build on Arch Linux (since there's nothing that provides
QC1), in turning preventing HDBC and lots of other of your packages.

Might be a good time to move to QC2 soon - it provides test case
shrinking and other handy features.

-- Don

More information about the arch-haskell mailing list