[arch-haskell] Packages in [extra] and [community] with missing deps

Don Stewart dons at galois.com
Tue Jan 26 14:38:13 EST 2010

> E.g.
>     http://www.archlinux.org/packages/community/i686/haskell-http/
> Should depend on haskell-parsec, haskell-mtl and haskell-network (which
> used to be provided by GHC). 
> The binary package doesn't list those deps though. A modern package
> build for this package is on AUR. We'll need to double check the others.
>    http://aur.archlinux.org/packages.php?ID=33917
>    Dependencies ghc haskell-array haskell-bytestring haskell-cabal
>                 haskell-mtl haskell-network haskell-old-time haskell-parsec 
> Vegai, do you want me to regenerate on AUR all the [extra] and
> [community] package builds, via cabal2arch, and you can upload them into
> the binary repos?


    regex-compat-0.92: dependency "reReading package info from stdin ...
    regex-base-0.93.1-812f60adac54e97264ef3bf5f6dec4a7" doesn't exist (use
    --force to override)
    regex-compat-0.92: dependency
    "regex-posix-0.94.1-042f2b271d4d6f77e6a868ed83d974cf" doesn't exist
    (use --force to override)

So missing regex-base and -posix deps.

Cool to see the new ghc-pkg catching this.

More information about the arch-haskell mailing list