[arch-haskell] cabal2arch 0.6.1 now generates bad dependencies

Magnus Therning magnus at therning.org
Sat Jan 16 06:04:21 EST 2010

On Sat, Jan 16, 2010 at 10:57 AM, Tasha Buckley
<etherealgoddess at gmail.com> wrote:
> Hello again,
> cabal2arch 0.6.1 seems to only be generating dependencies consisting
> of ghc and haskell-cabal.
> This is problematic since ghc 6.12 already includes Distribution.Cabal
> and a few packages have dependencies besides these two :P

I thought 6.10 came with Cabal as well, and that it was dealt with by
having 'ghc' provide 'haskell-cabal' in Arch.

I notice that now the 'provides' in GHC 6.12 is much improved, excellent.


Magnus Therning                        (OpenPGP: 0xAB4DFBA4)
magnus@therning.org          Jabber: magnus@therning.org
http://therning.org/magnus         identi.ca|twitter: magthe

More information about the arch-haskell mailing list