[arch-haskell] Proper dependencies, please!

Don Stewart dons at galois.com
Wed Oct 14 01:51:23 EDT 2009

> Yesterday there was an update to haskell-x11 available ( and pacman
> was happy with installing it.  GHC however, was not since a few of the other
> installed packages depended on version 1.4.5.  Despite ghc-pkg complaining
> loudly pacman pushed on and in the end I was left with a somewhat broken
> system.
> To fix it I ran "pacman -Rcs haskell-x11", but that of course means I can't
> use xmonad until it has been recompiled against the newer haskell-x11.
> AFAICS this all stems from xmonad having the dependency on
> "haskell-x11" when it in fact ought be on "haskell-x11>=1.4.5 haskell<1.4.6".
> Is it possible to get these more specific dependencies into PKGBUILDs in some
> automated fashion, so that breakage like this can be easily avoided?

Ah, so the binary xmonad has more precise dependencies than the src
xmonad -- so when cabal2arch generates a PKGBUILD -- one that works for
AUR -- it will actually be subtly broken for the binary installs, where
the ABI compat requires only one version of each dependency.

I think we could do this -- it would be done when moving a PKGBUILD into
the binary repos -- and pinning the version at that point.

-- Don

More information about the arch-haskell mailing list