[arch-haskell] ghc-6.10.2 in extra

Don Stewart dons at galois.com
Sat Apr 25 03:02:11 EDT 2009

> On Fri, Apr 24, 2009 at 11:12:56PM -0400, Adam Vogt wrote:
> > Many packages in [community] remain to be rebuilt against the new ghc.
> > 
> > Perhaps we should depend on specific ghc versions: that way pacman will 
> > enforce the dependencies: it won't really reduce the work required to 
> > upgrade ghc, but I think that it might be more clear that said installed 
> > libraries won't work.
> I agree. In fact, my packages in community already do this. 

That's an interesting idea. [community] is smaller than AUR, so it may
be feasible to tag with the required GHC.

I don't think this would help AUR, though.

-- Don

More information about the arch-haskell mailing list