<div dir="ltr">One messy sketch of how this could proceed would be to make additional Addr-based analogues of the report specified type-unrelated "Ptr a" functions and install them side by side with the existing functions. This would behave much like how we have both readsPrec and readPrec for standard vs. GHC specific Read internals. With MINIMAL pragmas it should basically become transparent if they are mutually defined. Since generally Storable dictionaries aren't built out of compositions of other Storable dictionaries, growing the class shouldn't do any measurable harm to performance. We haven't been shy about adding new members to report-specified classes like Bits. This doesn't strike me as much different.<div><br></div><div>At some point in the future we can work out if it is worth it to get the report fixed up by incorporating the Addr-based API as the default and make the _other_ the legacy.</div><div><br></div><div>-Edward<br><div><br></div></div></div><br><div class="gmail_quote"><div dir="ltr">On Tue, Oct 30, 2018 at 10:11 AM Sven Panne <<a href="mailto:svenpanne@gmail.com">svenpanne@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_quote"><div>I am not sure if everybody fully comprehends what Storable is all about: It is meant as the lowest-level building block in an Addr-free world (remember: Addr is a GHCism and is *not* mentioned anywhere in the report) to put a few well-defined simple Haskell types into memory or read them from there. Its explicit non-goals are:</div><div><br></div><div>   * Achieve 100% type safety. In the presence of raw memory access, castPtr, C calls etc. this would be a total illusion. Forcing API users to sprinkle tons of castPtr at every possible place over their code wouldn't improve safety at all, it would only hurt readability.</div><div><br></div><div>   * Handle more complicated sum/product types. How would you do this? Respect your native ABI (i.e. automatically handle padding/alignment)? Tightly packed? Or even handle a foreign ABI? Your own ABI? Some funny encoding like OpenGL's packed data types? Etc. etc. You can build all of those things in a layer above Storable, probably introducing other type classes or some marshaling DSLs.</div><div><br></div><div>   * Portability of the written values. This is more in the realm of serialization libraries.</div><div><br></div><div>More concretely:</div><div><br></div><div dir="ltr">Am Di., 30. Okt. 2018 um 14:34 Uhr schrieb Daniel Cartwright <<a href="mailto:chessai1996@gmail.com" target="_blank">chessai1996@gmail.com</a>>:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div>[19:26:50] <chessai_> hPutBuf :: Handle -> Ptr a -> Int -> IO () [...]</div></div></div></blockquote><div><br></div><div>The signature for this is actually perfect: hPutBuf doesn't care about what stuff has been written into the given buffer, it just cares about its start and its size. Forcing castPtr Kung Fu here wouldn't buy you anything: The buffer will probably contain a wild mix of Haskell values or even no Haskell values at all, but that doesn't matter. Whatever you pass as "a" or whatever you cast from/to is probably a lie from the typing perspective. At this level this is no problem at all.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div>[19:30:02] <chessai_> peekByteOff :: Ptr b -> Int -> IO a<br></div><div>[19:30:09] <chessai_> peekByteOff :: Addr -> Int -> IO a</div><div>[19:30:26] <chessai_> what is 'b' doing there? it's not used in any meaningful way by peekByteOff [...]</div></div></div></blockquote><div><br></div><div>If you have a pointer pointing to something and shift that pointer by some bytes, you are probably pointing to something completely different, so of course "b" and "a" have nothing to do with each other. So peekByteOff intentionally ignores "b".</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div>[19:32:22] <carter> pokeElemOff :: Ptr a -> Int -> a -> IO () --- way better than peak  [...]<br></div></div></div></blockquote><div><br></div><div>Yes, because this is intended to be used for *arrays* of values of the same type. Note "Elem" vs. "Byte".</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div></div><div>[19:33:12] <carter> hvr: lets add safePeekByteOff :: Ptr a -> Int -> IO a ? [...]<br></div></div></div></blockquote><div><br></div><div>This signature doesn't make sense, see above: Shifting a pointer by an arbitrary amount of bytes will probably change the type of what you're pointing to. If you shift by units of the underlying type, well, that's peekElemOff.</div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div></div><div>[19:35:31] <chessai_> carter: i am glad we agree on the smell<br></div></div></div></blockquote><div><br></div><div>I don't have the full chat log, but I think I don't even agree on the smell, at least not at the places I've seen... :-) </div><div><br></div><div><br></div></div></div>
_______________________________________________<br>
Libraries mailing list<br>
<a href="mailto:Libraries@haskell.org" target="_blank">Libraries@haskell.org</a><br>
<a href="http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries" rel="noreferrer" target="_blank">http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries</a><br>
</blockquote></div>