<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">2015-09-30 17:02 GMT+02:00 Casey McCann <span dir="ltr"><<a href="mailto:cam@uptoisomorphism.net" target="_blank">cam@uptoisomorphism.net</a>></span>:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><span class="">On Wed, Sep 30, 2015 at 10:29 AM, Sven Panne <<a href="mailto:svenpanne@gmail.com">svenpanne@gmail.com</a>> wrote:<br>
>   * Should OpenGLRaw use pattern synonyms? (Probably yes, but note that this<br>
> implies GHC >= 7.8.1)<br>
><br>
>   * Should OpenGLRaw use the 'Half' type from the 'half' package? (Probably<br>
> yes, but again this implies GHC 7.8.1)<br>
<br>
</span>7.8.1 is, what, a year and a half old?<br>
<br>
I'm all for bleeding edge personally but not everyone feels that way,<br>
and that seems pretty severe relative to the benefits.<br></blockquote><div><br></div><div>That's my biggest concern, too, and that's why I wanted to hear other people's opinions: IMHO using pattern synonyms vs. plain old Haskell values is to a large part just bikeshedding, at least in the trivial case at hand where we talk about simple integral values. It basically boils down to the question: Is</div><div><br></div><div>   foo x = case x of</div><div>     GL_BAR -> expr1</div><div>     GL_BAZ -> expr2</div><div>     _ -> expr3</div><div><br></div><div>really so much better than</div><div><br></div><div>   foo x</div><div>     | x == GL_BAR = expr1</div><div><div>     | x == GL_BAZ = expr2</div></div><div>     | otherwise = expr3</div><div><br></div><div>that we want to drop support for GHC < 7.8.1? Personally, I'm not convinced, but if most other people think that it's OK, I'm willing to pay the price for the sake of merging the packages. Edward claims that using pattern synonyms will result in more efficient code, too, but I haven't checked that. And even if it was: Perhaps GHC can be tweaked to treat both versions above in the same way (I can see no reason why this shouldn't be possible, but perhaps I'm wrong). Regarding readability: The version with pattern synonyms *is* slightly more readable, but not so much that it would warrant dropping slightly outdated GHCs.</div><div><br></div><div>Regarding the 'half' package: I've just seen that it should work with any GHC 7.x now, so this decision can be decoupled from the pattern synonym issue. Perhaps I should release a new, only slightly incompatible OpenGLRaw version using 'half'? Although GLhalf is part of OpenGL core since 3.0, it is only used in very few non-central places (GL_ARB_half_float_pixel, GL_ARB_half_float_vertex, and GL_NV_half_float). So the resulting breakage will probably be very low.</div><div><br></div><div>Regarding the module prefix: I'm not sure if it's worth making this breaking change alone, probably this should only be done in conjunction with the introduction of pattern synonyms. But other opinions would be valuable here, too.</div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">[...] As an aside regarding the wiki discussion, I don't really see how<br>
there's a sane way to have a combined low-level API for WebGL and full<br>
OpenGL. [...]</blockquote><div><br></div><div>As already mentioned in more detail on the Wiki, the plan to combine OpenGL and WebGL in a single package is doomed: Different values for the same token, different contents of the extensions, different ways to retrieve the entry points. It's a pity, but that's how it is...</div></div></div></div>