[commit: ghc] master: Use newBlockId instead of newLabelC (4d4e7a5)

git at git.haskell.org git at git.haskell.org
Tue Nov 29 21:38:00 UTC 2016


Repository : ssh://git@git.haskell.org/ghc

On branch  : master
Link       : http://ghc.haskell.org/trac/ghc/changeset/4d4e7a512aa4ecbb5811cccc1dab335379e63efa/ghc

>---------------------------------------------------------------

commit 4d4e7a512aa4ecbb5811cccc1dab335379e63efa
Author: Ben Gamari <bgamari.foss at gmail.com>
Date:   Tue Nov 29 14:44:19 2016 -0500

    Use newBlockId instead of newLabelC
    
    This seems like a clearer name and the fewer functions that
    one needs to remember, the better.
    
    Test Plan: validate
    
    Reviewers: austin, simonmar, michalt
    
    Reviewed By: simonmar, michalt
    
    Subscribers: thomie
    
    Differential Revision: https://phabricator.haskell.org/D2735


>---------------------------------------------------------------

4d4e7a512aa4ecbb5811cccc1dab335379e63efa
 compiler/cmm/BlockId.hs           |  5 +++++
 compiler/cmm/CmmLayoutStack.hs    |  3 +--
 compiler/codeGen/StgCmmBind.hs    |  3 ++-
 compiler/codeGen/StgCmmExpr.hs    |  6 +++---
 compiler/codeGen/StgCmmExtCode.hs | 11 +++++++----
 compiler/codeGen/StgCmmForeign.hs |  3 ++-
 compiler/codeGen/StgCmmHeap.hs    | 13 +++++++------
 compiler/codeGen/StgCmmLayout.hs  | 11 ++++++-----
 compiler/codeGen/StgCmmMonad.hs   | 25 ++++++++++---------------
 compiler/codeGen/StgCmmPrim.hs    |  3 ++-
 compiler/codeGen/StgCmmUtils.hs   |  6 +++---
 11 files changed, 48 insertions(+), 41 deletions(-)

Diff suppressed because of size. To see it, use:

    git diff-tree --root --patch-with-stat --no-color --find-copies-harder --ignore-space-at-eol --cc 4d4e7a512aa4ecbb5811cccc1dab335379e63efa


More information about the ghc-commits mailing list