[commit: ghc] wip/dph-fix's head updated: Make Applicative-Monad fixes for tests. (daf3c22)

git at git.haskell.org git at git.haskell.org
Thu Oct 2 21:44:25 UTC 2014


Repository : ssh://git@git.haskell.org/ghc

Branch 'wip/dph-fix' now includes:

     e9cd1d5 Less voluminous output when printing continuations
     6e0f6ed Refactor unfoldings
     3af1adf Kill unused setUnfoldingTemplate
     8f09937 Make maybeUnfoldingTemplate respond to DFunUnfoldings
     9cf5906 Make worker/wrapper work on INLINEABLE things
     4c03791 Specialise Eq, Ord, Read, Show at Int, Char, String
     3436333 Move the Enum Word instance into GHC.Enum
     949ad67 Don't float out (classop dict e1 e2)
     2ef997b Slightly improve fusion rules for 'take'
     99178c1 Specialise monad functions, and make them INLINEABLE
     baa3c9a Wibbles to "...plus N others" error message about instances in scope
     a3e207f More SPEC rules fire
     dce7095 Compiler performance increases -- yay!
     b9e49d3 Add -fspecialise-aggressively
     fa582cc Fix an egregious bug in the NonRec case of bindFreeVars
     6d48ce2 Make tidyProgram discard speculative specialisation rules
     86a2ebf Comments only
     1122857 Run float-inwards immediately before the strictness analyser.
     082e41b Testsuite wibbles
     bb87726 Performance changes
     a0b2897 Simple refactor of the case-of-case transform
     6c6b001 Remove dead lookup_dfun_id (merge-o)
     39ccdf9 White space only
     a1a400e Testsuite wibbles
     1145568 testsuite: disable T367_letnoescape on 'optllvm'
     75d998b testsuite: disable 'rdynamic' for 'ghci' way
     94926b1 Add an interesting type-family/GADT example of deletion for red-black trees
     87c1568 Comments only
     b7bdf13 Temporary fix to the crash
     aa49892 [ci skip] ghc-prim: Update .gitignore
     8270ff3 [ci skip] Update .gitignore
     9072f2f PprC: cleanup: don't emit 'FB_' / 'FE_' in via-C
     49370ce Improve trimming of auto-rules
     4a87142 Fix syntax in perf/compiler/all.T
     7eae141 White space only
     2da63c6 Better compiler performance (30% less allocation) for T783!
     dfc9d30 Define mapUnionVarSet, and use it
     8df3159 Rename red-black test in indexed-types to red-black-delete
     db5868c In GHC.Real, specialise 'even' and 'odd' to Int and Integer
     9fae691 Improve "specImport discarding" message
     b2affa0 Testsuite wibbles
     69e9f6e Simplify conversion in binary serialisation of ghc-pkg db
     557c8b8 Drop support for single-file style package databases
     ce29a26 Improve the ghc-pkg warnings for missing and out of date package cache files
     8d7a1dc Introduce new file format for the package database binary cache
     27d6c08 Use ghc-local types for packages, rather than Cabal types
     0af7d0c Move Cabal Binary instances from bin-package-db to ghc-pkg itself
     9597a25 Drop ghc library dep on Cabal
     227205e Make binary a boot package
     6930a88 Fix warnings arising from the package db refactoring
     29f84d3 Fix long lines and trailing whitespace
     8955b5e Remove a TODO that is now done
     a4cb9a6 Add a ghc -show-packages mode to display ghc's view of the package env
     1bc2a55 Make mkFastStringByteString pure and fix up uses
     c72efd7 Switch the package id types to use FastString (rather than String)
     b00deb7 Fix string conversions in ghc-pkg to be correct w.r.t. Unicode
     42f99e9 Address a number of Edward's code review comments
     9d6fbcc Fix validation error in Linker arising from package rep changes
     01461ce Update Cabal and haddock submodules to follow the Canal-dep removal changes
     da72898 Change testsuite to not use old-style file package databases
     616dd87 Fix a few minor issues spotted in code review
     6d8c70c Add release notes about ghc-pkg change, and Cabal dep removal
     020bd49 Fix failing test on BINDIST=YES
     cb2ac47 Suppress binary warnings for bootstrapping as well as stage1.
     f0db185 Include pattern synonyms as AConLikes in the type environment, even for simplified/boot ModDetails (fixes #9417)
     4e0e774 Fix a bug in CSE, for INLINE/INLNEABLE things
     ab4c27e Comments, white space, and rename "InlineRule" to "stable unfolding"
     3521c50 When finding loop breakers, distinguish INLINE from INLINEABLE
     7af33e9 Better specImport discarding message (again)
     e5f766c Give the worker for an INLINABLE function a suitably-phased Activation
     3935062 Finally!  Test Trac #6056
     5da580b Performance improvement of the compiler itself
     fa9dd06 Do not say we cannot when we clearly can
     9491fea Typos in comments
     eac8728 Fix to bin-package-db for ming32-only code
     985e367 testsuite: normalise integer library name for T8958
     0dc2426 Some typos
     54db6fa Revert "Comment why the include is necessary"
     b760cc5 Revert "Make sure that a prototype is included for 'setIOManagerControlFd'"
     393b820 Re-export Word from Prelude (re #9531)
     a8a969a Add `FiniteBits(count{Leading,Trailing}Zeros)`
     737f368 `M-x delete-trailing-whitespace` & `M-x untabify`...
     3241ac5 Remove incorrect property in docstring (re #9532)
     a4ec0c9 Make ghc-api cleaning less aggressive.
     01a27c9 testsuite: update T6056 rule firing order
     e81e028 includes/Stg.h: remove unused 'wcStore' inline
     9e93940 StringBuffer should not contain initial byte-order mark (BOM)
     0f31c2e Cleanup and better documentation of sync-all script
     64c9898 Make Lexer.x more like the 2010 report
     3be704a genprimopcode: GHC.Prim is Unsafe (#9449)
     2f343b0 Refactor stack squeezing logic
     918719b Set llc and opt commands on all platforms
     9711f78 Fix a couple test failures encountered when building on Windows
     4d4d077 systools: fix gcc version detecton on non-english locale
     31f43e8 Revert "Fix a couple test failures encountered when building on Windows"
     8c427eb Remove max_bytes_used test from haddock test cases
     8b107b5 rts/Printer.c: update comments about using USING_LIBBFD
     9692393 configure.ac: cleanup: remove unused 'HaveLibDL' subst
     1719c42 Update nofib submodule: Hide Word from Prelude
     e428b5b Add Data.List.uncons
     89baab4 Revert "Remove max_bytes_used test from haddock test cases"
     498d7dd Do not test max_bytes_used et. al for haddock tests
     b5a5776 Update performance numbers (mostly improved)
     3034dd4 Another test for type function saturation
     4c359f5 Small improvement to unsaturated-type-function error message
     6af1c9b Add missing changelog/since entry for `uncons`
     e18525f pprC: declare extern cmm primitives as functions, not data
     55e4e5a Revert "Do not test max_bytes_used et. al for haddock tests"
     7bf7ca2 Do not use max_bytes_used for haddock test
     7d3f2df PostTcType replaced with TypeAnnot
     5a1def9 Update T4801 perf numbers
     78209d7 INLINE unfoldr
     f0e725a Typos
     049bef7 rules: cleanup: use '$way_*suf' var instead of open-coded '($3_way_)s'
     fdfe6c0 rules: fix buld failure due to o-boot suffix typo
     d94de87 Make Applicative a superclass of Monad
     0829f4c base: Bump version to 4.8.0.0
     27a642c Revert "base: Bump version to 4.8.0.0"
     c6f502b Bump `base` version to 4.8.0.0 for real
     68ecc57 base: replace ver 4.7.1.0 references by 4.8.0.0
     841924c build.mk.sample: Stage1 needn't be built with -fllvm
     1e40037 Update nofib submodule to fix errors in main suite.
     f3d2694 Update nofib submodule to track gc bitrot updates.
     6477b3d testsuite: AMPify ioprof.hs
     29e50da testsuite: AMPify T3001-2
     71c8530 Update performance numbers
     57fd8ce Fix T5321Fun perf number
     23e764f T4801 perf numbers: Another typo
     c0c1772 Kill obsolete pre GHC 7.6 bootstrapping support
     0b54f62 Make GHC `time-1.5`-ready
     695d15d Update nofib submodule: Update gitignore with more generated files
     946cbce Fix support for deriving Generic1 for data families (FIX #9563)
     9d71315 Remove obsolete comment about (!!)
     b10a7a4 base: Drop obsolete/redundant `__GLASGOW_HASKELL__` checks
     b53c95f Move ($!) from Prelude into GHC.Base
     45cd30d Follow-up to b53c95fe621d3a66a82e6dad383e1c0c08f3871e
     6999223 Fixup test-case broken by Follow-up to b53c95fe621
     abff2ff Move docstring of `seq` to primops.txt.pp
     2cd76c1 Detabify primops.txt.pp
     5fbd4e36 Update haskell2010 submodule
     39e206a Update libffi-tarballs submodule to libffi 3.1 (re #8701)
     004c5f4 Tweak perf-numbers for T1969 and T4801
     c0fa383 Export `Traversable()` and `Foldable()` from Prelude
     df2fa25 base: Remove bunk default impl of (>>=)
     65f887e base: Add some notes about the default impl of '(>>)'
     b72478f Don't offer hidden modules for autocomplete.
     f8ff637 Declare official GitHub home of libraries/filepath
     a9b5d99 Mark T8639_api/T8628 as PHONY
     72d6d0c Update config.{guess,sub} to GNU automake 1.14.1
     d24a618 Follow-up to 72d6d0c2704ee6d9 updating submodules for real
     628b21a haskeline: update submodule to fix Windows breakage
     cdf5a1c Add special stdout for hClose002 on x64 Solaris
     cfd8c7d Find the target gcc when cross-compiling
     3681c88 Fix cppcheck warnings
     fe9f7e4 Remove special casing of singleton strings, split all strings.
     52eab67 Add the ability to :set -l{foo} in ghci, fix #1407.
     caf449e Return nBytes instead of nextAddr from utf8DecodeChar
     7e658bc Revert "Revert "rts/base: Fix #9423"" and resolve issue that caused the revert.
     e7a0f5b Fix typo "Rrestriction" in user's guide (lspitzner, #9528)
     b475219 Move `Maybe`-typedef into GHC.Base
     1574871 Re-add SPECIALISE liftM* pragmas dropped in d94de87252d0fe
     9b8e24a Typo
     74f0e15 Simplify
     3c28290 Typo in comment
     b62bd5e Implement `decodeDouble_Int64#` primop
     2622eae Remove unnecessary imports in GHC.Event.KQueue to fix compiler warnings.
     393f0bb Comments only: explain checkAxInstCo in OptCoercion
     a8d7f81 Update haddock submodule for package key fix.
     c4c8924 Fix formatting bug in core-spec.
     8b90836 Move (=<<) to GHC.Base
     eae1911 Move `when` to GHC.Base
     a94dc4c Move Applicative/MonadPlus into GHC.Base
     fbf1e30 Move Control.Monad.void into Data.Functor
     af22696 Invert module-dep between Control.Monad and Data.Foldable
     b406085 Generalise Control.Monad.{sequence_,msum,mapM_,forM_}
     ed58ec0 Revert "Update haddock submodule for package key fix."
     275dcaf Add -fwarn-context-quantification (#4426)
     8c79dcb Update haddock submodule (miscellaneous fixes)
     e12a6a8 Propositional equality for Datatype meta-information
     0a8e6fc Make constructor metadata parametrized (with intended parameter <- datatype)
     f097b77 Implement sameConstructor
     cc618e6 get roles right and fix a FIXME
     79c7125 Actually parametrize the Constructor with the Datatype
     7bd4bab Supply a reasonable name (should be derived from d_name tho)
     09fcd70 Use 'd_name' as the name (should be derived from d_name tho)
     4d90e44 Add default case (fixes -Werror)
     6d84b66 Revert accidental wip/generics-propeq-conservative merge
     fdc03a7 Auto-derive a few manually coded Show instances
     c96c64f Increase -fcontext-stack=N default to 100
     ebb7334 Spelling error in flags.xml
     48f17f1 Use mapAccumL (refactoring only)
     2a5eb83 Typo in comment in GHC.Generics
     1378ba3 Fix garbled comment wording
     28059ba Define Util.leLength :: [a] -> [b] -> Bool
     24e51b0 White space only
     0aaf812 Clean up Coercible handling, and interaction of data families with newtypes
     e1c6352 Fixup overlooked `unless` occurence
     d48fed4 Define fixity for `Data.Foldable.{elem,notElem}`
     5e300d5 Typos
     e76fafa Fix potential `mingw32_HOST_OS` breakage from eae19112462fe77
     83c5821 Fix potential `mingw32_HOST_OS` -Werror failure
     4805abf Deactive T4801 `max_bytes_used`-check & bump T3064 numbers
     9f7e363 Change linker message verbosity to `-v2` (re #7863)
     3daf002 Set up framework for generalising Data.List to Foldables
     1812898 Turn a few existing folds into `Foldable`-methods (#9621)
     05cf18f Generalise (some of) Data.List to Foldables (re #9568)
     ed65808 Add missing changelog entries for current state of #9586
     e7c1633 Simplify import-graph a bit more
     bfc7195 Update haskell2010, haskell98, and array submodules
     835d874 Make libffi install into a predictable directory (#9620)
     5ed1281 Move `mapM` and `sequence` to GHC.Base and break import-cycles
     1f7f46f Generalise Data.List/Control.Monad to Foldable/Traversable
     b8f5839 Export `Monoid(..)`/`Foldable(..)`/`Traversable(..)` from Prelude
     27b937e Fix windows breakage from 5ed12810e0972b1e due to import cycles
     38cb5ec Update haskeline submodule to avoid -Werror failure
     5fa6e75 Ensure that loop breakers are computed when glomming
     01906c7 Test Trac #9565 and #9583
     2a743bb Delete hack when takeDirectory returns ""
     330bb3e Delete all /* ! __GLASGOW_HASKELL__ */ code
     d5e4874 Change all hashbangs to /usr/bin/env (#9057)
     165072b Adapt nofib submodule to #9586 changes
     4b648be Update Cabal submodule & ghc-pkg to use new module re-export types
     805ee11 `M-x delete-trailing-whitespace` & `M-x untabify`
     fb84817 `M-x delete-trailing-whitespace` & `M-x untabify`
     6b02626 Update time submodule to 1.5.0 release
     f1d8841 Link from 7.6.3.4 to 7.7.2.6 in the user guide.
     55e04cb Remove a few redundant `-fno-warn-tabs`s
     46a5b7c Detab DataCon
     3ecca02 Update `binary` submodule in an attempt to address #9630
     c315702 [ci skip] iface: detabify/dewhitespace IfaceSyn
     3765e21 [ci skip] simplCore: detabify/dewhitespace CoreMonad
     7567ad3 [ci skip] typecheck: detabify/dewhitespace TcInstDecls
     c4ea319 [ci skip] typecheck: detabify/dewhitespace TcPat
     a3dcaa5 [ci skip] typecheck: detabify/dewhitespace TcTyDecls
     18155ac [ci skip] typecheck: detabify/dewhitespace TcUnify
     efdf4b9 types: detabify/dewhitespace Unify
     dc1fce1 Refer to 'mask' instead of 'block' in Control.Exception
     a7ec061 Delete hack that was once needed to fix the build
     2388146 User's Guide: various unfolding-related fixes
     c23beff Fixes cyclic import on OS X(#9635)
     74ae598 Defer errors in derived instances
     20632d3 Do not discard insoluble Derived constraints
     8c9d0ce Wibble to implicit-parameter error message
     1a88f9a Improve error messages from functional dependencies
     0e16cbf Two improved error messages
     ac157de Complain about illegal type literals in renamer, not parser
     0ef1cc6 De-tabify and remove trailing whitespace
     0686897 This test should have -XDataKinds
     2e4f364 Comments
     c5f65c6 Update `unix` submodule to disable getlogin tests
     319703e Don't re-export `Alternative(..)` from Control.Monad (re #9586)
     4b9c92b Update Cabal submodule to latest master branch tip
     b3aa6e4 Replace obsolete `defaultUserHooks` by `autoconfUserHooks`
     51aa2fa Stop exporting, and stop using, functions marked as deprecated
     f636faa Set default-impl of `mapM`/`sequence` methods to `traverse`/`sequenceA`
     071167c User's Guide: Fix compiler plugin example (#9641, #7682)
     a07ce16 Generalise `Control.Monad.{when,unless,guard}`
     bf33291 Generalise `guard` for real this time
     e5cca4a Extend `Foldable` class with `length` and `null` methods
     ee15686 Fixup nofib submodule to cope with e5cca4ab246ca2
     e97234d bugfix: EventCapsetID should be EventThreadID
     aeb9c93 Document that -dynamic is needed for loading compiled code into GHCi
     7371d7e Revert "rts: add Emacs 'Local Variables' to every .c file"
     23bb904 Add emacs indentation/line-length settings
     5d16c4d Update hsc2hs submodule
     8d04eb2 Fix bogus comment
     04ded40 Comments about the let/app invariant
     1c10b4f Don't use newSysLocal etc for Coercible
     864bed7 Update Win32 submodule to avoid potential -Werror failure
     488e95b Make foldr2 a bit more strict
     4e1dfc3 Make scanr a good producer and consumer
     d41dd03 Make mapAccumL a good consumer
     7893210 Fusion rule for "foldr k z (x:build g)"
     96a4062 Make filterM a good consumer
     93b8d0f Simplify mergeSATInfo by using zipWith
     bcbb045 First stab at making ./validate less verbose
     15f661c update cabal submodule to fix build failure on Solaris
     f3b5e16 rts/includes: Fix up .dir-locals.el
     3a549ba [ci skip] compiler: Kill last remaining tabs in CallArity
     ca3089d [ci skip] Kill tabs in md5.h
     53a2d46 [ci skip] Kill unused count_bytes script
     2a88568 Use dropWhileEndLE p instead of reverse . dropWhile p . reverse
     084d241 Basic Python 3 support for testsuite driver (Trac #9184)
     644c76a Use LinkerInternals.h for exitLinker.
     b23ba2a Place static closures in their own section.
     3b5a840 BC-breaking changes to C-- CLOSURE syntax.
     178eb90 Properly generate info tables for static closures in C--.
     3567207 Rename _closure to _static_closure, apply naming consistently.
     146b56d Update primitive, vector, and dph.
     daf3c22 Make Applicative-Monad fixes for tests.


More information about the ghc-commits mailing list