[commit: ghc] master: Rename some of the functions in NameSet, to make the uniform with VarSet etc (7460daf)

git at git.haskell.org git at git.haskell.org
Fri Nov 28 17:37:28 UTC 2014


Repository : ssh://git@git.haskell.org/ghc

On branch  : master
Link       : http://ghc.haskell.org/trac/ghc/changeset/7460dafae3709218af651cb8bc47b5f03d4c25c7/ghc

>---------------------------------------------------------------

commit 7460dafae3709218af651cb8bc47b5f03d4c25c7
Author: Simon Peyton Jones <simonpj at microsoft.com>
Date:   Fri Nov 28 17:35:44 2014 +0000

    Rename some of the functions in NameSet, to make the uniform with VarSet etc
    
    For ages NameSet has used different names,
      eg.   addOneToNameSet   rather than    extendNameSet
            nameSetToList     rather than    nameSetElems
    
    etc.  Other set-like modules use uniform naming conventions.
    This patch makes NameSet follow suit.
    
    No change in behaviour; this is just renaming.
    
    I'm doing this just before the fork so that merging is easier.


>---------------------------------------------------------------

7460dafae3709218af651cb8bc47b5f03d4c25c7
 compiler/basicTypes/Avail.hs                  |  2 +-
 compiler/basicTypes/MkId.lhs                  |  2 +-
 compiler/basicTypes/NameSet.lhs               | 44 +++++++++++++--------------
 compiler/basicTypes/RdrName.lhs               |  6 ++--
 compiler/coreSyn/CoreFVs.lhs                  | 16 +++++-----
 compiler/deSugar/Coverage.lhs                 |  2 +-
 compiler/ghci/ByteCodeAsm.hs                  |  2 +-
 compiler/ghci/Linker.hs                       |  4 +--
 compiler/hsSyn/HsUtils.lhs                    | 12 ++++----
 compiler/iface/IfaceSyn.lhs                   |  2 +-
 compiler/iface/MkIface.lhs                    | 18 +++++------
 compiler/main/GHC.hs                          |  2 +-
 compiler/main/HscTypes.lhs                    |  2 +-
 compiler/main/InteractiveEval.hs              |  2 +-
 compiler/rename/RnBinds.lhs                   |  6 ++--
 compiler/rename/RnExpr.lhs                    | 18 +++++------
 compiler/rename/RnNames.lhs                   |  8 ++---
 compiler/rename/RnSource.lhs                  | 12 ++++----
 compiler/typecheck/TcBinds.lhs                |  2 +-
 compiler/typecheck/TcInstDcls.lhs             |  2 +-
 compiler/typecheck/TcRnDriver.lhs             |  2 +-
 compiler/typecheck/TcRnMonad.lhs              |  2 +-
 compiler/typecheck/TcSplice.lhs               |  2 +-
 compiler/typecheck/TcTyDecls.lhs              |  6 ++--
 compiler/typecheck/TcType.lhs                 | 32 +++++++++----------
 compiler/types/FamInstEnv.lhs                 |  2 +-
 compiler/types/TyCon.lhs                      |  2 +-
 compiler/vectorise/Vectorise/Monad.hs         |  2 +-
 compiler/vectorise/Vectorise/Type/Classify.hs |  2 +-
 compiler/vectorise/Vectorise/Type/Env.hs      |  2 +-
 30 files changed, 109 insertions(+), 109 deletions(-)

Diff suppressed because of size. To see it, use:

    git diff-tree --root --patch-with-stat --no-color --find-copies-harder --ignore-space-at-eol --cc 7460dafae3709218af651cb8bc47b5f03d4c25c7


More information about the ghc-commits mailing list